Cisco IOS — Link Aggregation with LACP and NIC Teaming

Hi All!, been awhile since I posted an article and I don’t think I have ever posted one on Network Link Aggregation!! Link Aggregation is the physical combining of network links into one logical link. There are two main advantages to this practice. First is the increase throughput that you obtain by combining links, for example combining 2x 1GB links will increase your total bandwidth to 2GB.(Keep in mind this will not change your latency…) Secondly, link aggregation grants the benefits of redundancy. Imagine the setup above. If 1 of the 1GB links fails, you would still have the other 1GB link to fall back on, woot!.

Wikipedia Image
–Image From Wikipedia

Terminology:

  • Link Aggregation Group (LAG) — is the set of physical ports, connections, etc contained within a logical group.
  • EtherChannel/PortGroup/NIC Teaming — are all vendor specific terms for LAGs. The underlying protocol used is explicitly configured by the administrator.
  • Trunk — I’ve heard LAG called a Trunk before…but I don’t like calling it that. When I say trunk i think of a Trunk VLAN Link or a connection that carries multiple VLANs across it.

Protocols

Two commonly used LAG protocols used are 802.3ad LACP and PAgP .

LACP (Link Aggregation Control Protocol)

  • Negotiation —LACP PDUs are sent down each active link with the objective of finding at the other ned of the link an LACP enabled port. Once each link has negotiated that is capable of LACP, it exchanges keys which are used to prevent other unwanted ports from joining the aggregation. Keeps the ports in a LAG consistent.
  • Advantages — IEEE standard, and vendor agnostic.

PAgP (Port Aggregation Protocol)

  • Negotiation — Similar to LACP.
  • Vendor specific —PAgp is a Cisco proprietary protocol and will only work with Cisco devices. Special NICs are required as well.
  • Advantages — Let me know in the comments please…..

LAG modes

  • On — LAG is forced to form without negotiating
  • Off — No LAG will be formed, no matter what is sent to port.
  • Passive/Auto — Port will not initiate a LAG connection, but will listen for LAG negotiation packets.
  • Active/Desirable — Port will form a LAG and initiate a negotiating to the partner port, LAG will form if and only if parter port is in On or Passive mode.

Configuration

Switch Configuration

The switch I used was a Cisco 3750, you can also use this with any Switch that supports LAG or LACP(check with vendor on what they call it)

  1. Console into the Switch
  2. Create a Port-Channel itnerface
    SW1# configure 
    SW1(config)# interface port-channel 200 
    SW1(config-if)# switchport 
    SW1(config-if)# switchport mode access 
    SW1(config-if)# exit
  3. Configure each physical Link that will be part of the Port-Channel.
    >SW1(config)# interface GigabitEthernet 0/1
    SW1(config-if)# switchport
    SW1(config-if)# switchport mode access
    SW1(config-if)# channel-group 200 mode active
    SW1(config-if)# channel-protocol lacp
    SW1(config-if)# exit
    
    SW1(config)# interface GigabitEthernet 0/2
    SW1(config-if)# switchport
    SW1(config-if)# switchport mode access
    SW1(config-if)# channel-group 200 mode active
    SW1(config-if)# channel-protocol lacp
    SW1(config-if)# exit
    SW1(config)# exit
  4. Double check the etherchannel for both physical lports.
    SW1# show etherchannel 200 port-channel
  5. Don’t forget to save!
    SW1# wr me

Server Configuration

For my example I was using a HP DL380G6 which had an NIC card of HP Ethernet 1Gb 4-port 331FLR Adapter and running Windows Server 2008 R2 64-bit..

  1. Install latest NIC drivers, found here. Remember I am using Windows Server 2008 R2 64-bit.
  2. Install HP Network Configuration Utility, found here.
  3. Open the HP Network Configuration Utility and select the NIC ports you would like to “Team”, and Click Team.
  4. On the Team Properties dialog box, change the Team Type Selection to 802.3ad Dynamic with Fault Tolerance. Also name your Team Name to something appropriate like PChannel-100-toCore…
  5. Click OK and OK.
  6. This will create a new Network Adater.
  7. Edit this new Network Adapter with the IP information that you would like.
  8. Double check each Network Adapter associated with the NIC Teaming, you should see a new Protocol Adapter bound to the Network Adapter.

Limitations:

  • Each Physical Link has to be the same link speed, for example you cannot mix a 10GB link with a 1GB link to get 11GB.
  • Each Physical Link has to be connected to the same Switching Device(Can be stacked). Cannot span over separate switches. (Check out vPC!!)

Sources: